Level3 Radar data outage
Incident Report for Weather Decision Technologies
Resolved
This incident has been resolved.
Posted 6 months ago. Jan 22, 2019 - 18:24 UTC
Identified
NOAA is currently experiencing issues with Level3 radar data delivery. Level2 products are still available.
Posted 6 months ago. Jan 22, 2019 - 17:40 UTC
This incident affected: RadarScope.